Android実行時にError:ShouldNotReachHere() [hs_err_pid.log]

AndroidをEclipseで開発しているとき、実行すると次のようなエラーが起こることがあります。
このエラーが起こると、それ以降 同じエラーが発生してアプリの実行などができなくなります。

プロジェクトのディレクトリにhs_err_pidxxxx.logのようなログファイルが生成されます。

# A fatal error has been detected by the Java Runtime Environment:
#
# Internal Error (classFileParser.cpp:3174), pid=3300, tid=4016
# Error: ShouldNotReachHere()
#
# JRE version: 6.0_20-b02
# Java VM: Java HotSpot(TM) Client VM (16.3-b01 mixed mode windows-x86 )
# An error report file with more information is saved as:
# C:\workspace\TestApp\hs_err_pid3300.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#

スポンサーリンク

このエラーはJUnitが関係しているようです。
実行の構成からJUnit Testなどの設定を調整すると、エラーが起こらなくなります。





またAndroid実行環境のJREのバージョンとEclipseのJREのバージョンが異なる場合も起こるようです。

関連記事

スポンサーリンク

enable シェル・コマンドを有効化,無効化する

ホームページ製作・web系アプリ系の製作案件募集中です。

上に戻る