jQueryのbgiframeプラグインをIE9に対応させる方法

jQueryで背景を透過色にしてLight Boxのように同HTML内の隠しコンテンツを表示させるプラグインにbgiframeプラグインがありますが、このbgiframeプラグインはInternet Explorer9には対応していません。
jquery.bgiframe.js
jquery.bgiframe.min.js
最新版は2007年7月21日に公開された2.1.1で、このバージョンでも正常に動作しません。

スポンサーリンク

IE9に対応させるにはIE6用に振り分けている部分の修正が必要です。

if ( $.browser.msie && /6.0/.test(navigator.userAgent) ) {

このコードを次のようにします。

if ( $.browser.msie && parseInt($.browser.version) === 6 ) {

bgiframeプラグイン

関連記事

スポンサーリンク

CELLING関数 最も小さい整数値を返す

ホームページ製作・web系アプリ系の製作案件募集中です。

上に戻る