CakePHPのバージョンごとのシステム要件

各バージョンに共通の要件

HTTPサーバ(例えばApacheなど)
mod_rewrite(必須条件ではない)

各バージョンごとのPHP、DB

バージョン PHP データベースエンジン
1.1 PHP4.3.2以上
PHP4と5に対応
MySQL (4以降)
PostgreSQL
ADOdb
1.2 PHP4.3.2以上
PHP4と5に対応
MySQL (4以降)
PostgreSQL
Firebird DB2
Microsoft SQL Server
Oracle
SQLite
ODBC
ADOdb
1.3 PHP4.3.2以上
PHP4と5に対応
MySQL (4以降)
PostgreSQL
Microsoft SQL Server
Oracle
SQLite
2 PHP5.3.0以上
(CakePHP2.6以下は、PHP5.2.8以上)
CakePHP2.8.0以上はPHP7に対応
PHP7.1以上はPECL経由でmcryptが必要
MySQL (4以上)
PostgreSQL
Microsoft SQL Server
SQLite
3 PHP 5.6以上
(PHP7.4も含む)
mbstring PHP拡張
intl PHP拡張
simplexml PHP拡張
MySQL(5.5.3以上)
MariaDB(5.5以上)
PostgreSQL
Microsoft SQL Server(2008 以上)
SQLite 3
4 PHP7.2以上
(PHP7.4も含む)
mbstring PHP拡張
intl PHP拡張
simplexml PHP拡張
MySQL(5.5.3以上)
MariaDB(5.5以上)
PostgreSQL
Microsoft SQL Server(2008 以上)
SQLite 3

スポンサーリンク

関連記事

スポンサーリンク

DELETE データ行の削除する

ホームページ製作・web系アプリ系の製作案件募集中です。

上に戻る